GuideReference
TrainingSupportCommunity

Breaking changes

v6.0

The release of v6.0 of the Akamai Terraform provider introduces these breaking changes.

Terraform provider

The Akamai provider requires use of ¬Īv1 of Terraform's provider.

To upgrade, add a required_version argument to the terraform block of your configuration with a value of >= 1.0 and reinitialize.

terraform {
  required_providers {
    akamai = {
      source  = "akamai/akamai"
      version = "6.0.0"
    }
  }
  required_version = ">= 1.0"
}

Property

The Property subprovider introduced two changes within the akamai_edge_hostname resource.

  • The resource now fails if you try to create a hostname that already exists or previously existed. Previously, passing the resource with the name of an existing hostname imported the hostname into your state.
  • The arguments product_id and certificate are now immutable and return an error on attempted update.