Sample configurations

Use these examples as a guideline when configuring Direct Connect.

Modify this according to your Direct Connect setup requirements.

Akamai ASN: 20189

Customer ASN: CPE_ASN

WAN IPv4 Assignment:

Akamai - x.x.x.0/31

Customer - x.x.x.1/31

WAN IPv6 Assignment:

Akamai - x:x:x:x::0/127

Customer - x:x:x:x::1/127

Sample CPE configuration (Juniper)

#Configure Point-to-Point Link as link bundle

set groups LACP-10g interfaces <*> aggregated-ether-options link-speed 10g

set groups LACP-10g interfaces <*> aggregated-ether-options lacp active
set groups LACP-10g interfaces <*> aggregated-ether-options lacp periodic slow

set interfaces xe-0/0/0:0 ether-options 802.3ad ae2

set interfaces ae2 apply-groups LACP-10g
set interfaces ae2 unit 0 family inet no-redirects
set interfaces ae2 unit 0 family inet address <x.x.x.1/31>
set interfaces ae2 unit 0 family inet6 address <x:x:x:x::1/127>

#Configure Point-to-Point BGP session for IPv4 and IPv6

set protocols bgp group Akamai_Direct Connect_group import <IMPORT POLICY NAME>
set protocols bgp group Akamai_Direct Connect_group export <EXPORT POLICY NAME>
set protocols bgp group Akamai_Direct Connect_group peer-as 20189
set protocols bgp group Akamai_Direct Connect_group neighbor <x.x.x.0> family inet unicast

set protocols bgp group Akamai_Direct Connect_group neighbor <x:x:x:x::0> family inet6 unicast

#Reject the more specific route (keeping the Aggregate route for backup) from IP Transit and Peering if applicable (Optional)

set protocols bgp group <IP_Transit_and_Peering_Group_Name> peer-as <IP Transit or Peering ASN>

set protocols bgp group <IP_Transit_and_Peering_Group_Name> import import_policy_IP_Transit_and_Peering

set policy-options policy-statement import_policy_IP_Transit_and_Peering term AKAMAI_Direct Connect_reject_more_specific_v4 from prefix-list-filter AKAMAI_Direct Connect_plist_v4 longer

set policy-options policy-statement import_policy_IP_Transit_and_Peering term AKAMAI_Direct Connect_reject_more_specific_v4 then reject

set policy-options policy-statement import_policy_IP_Transit_and_Peering term AKAMAI_Direct Connect_reject_more_specific_v6 from prefix-list-filter AKAMAI_Direct Connect_plist_v6 longer

set policy-options policy-statement import_policy_IP_Transit_and_Peering term AKAMAI_Direct Connect_reject_more_specific_v6 then reject

set policy-options policy-statement import_policy_IP_Transit_and_Peering <other terms continues here>

set policy-options prefix-list AKAMAI_Direct Connect_plist_v4 <IPv4 Aggregated Prefix provided by Akamai>

set policy-options prefix-list AKAMAI_Direct Connect_plist_v6 <IPv6 Aggregated Prefix provided by Akamai>

Sample CPE configuration (Cisco)

#Configure Point-to-Point Link as link bundle

interface Bundle-Ether2 ipv4 address <x.x.x.1/31>

interface Bundle-Ether2 ipv6 address <x:x:x:x::1/127>

interfaceBundle-Ether2 ipv6 enable

interface TenGigE0/0/0/0 bundle id 2 mode active

#Configure Point-to-Point BGP session for IPv4 and IPv6

router bgp <CPE_ASN> neighbor-group <GROUP-NAME> remote-as 20189

router bgp <CPE_ASN> neighbor-group <GROUP-NAME> address-family ipv4 unicast route-policy <IMPORT POLICY NAME> in

router bgp <CPE_ASN> neighbor-group <GROUP-NAME> address-family ipv4 unicast route-policy <EXPORT POLICY NAME> out

router bgp <CPE_ASN> neighbor-group <GROUP-NAME> address-family ipv6 unicast route-policy <IMPORT POLICY NAME> in

router bgp <CPE_ASN> neighbor-group <GROUP-NAME> address-family ipv6 unicast route-policy <EXPORT POLICY NAME> out

router bgp <CPE_ASN> neighbor <x.x.x.0> use neighbor-group <GROUP-NAME>

router bgp <CPE_ASN> neighbor <x:x:x:x::0> use neighbor-group <GROUP-NAME>

#Reject the more specific route (keeping the Aggregate route for backup) from IP Transit and Peering if applicable (Optional)

router bgp <CPE_ASN> neighbor-group <IP_Transit_and_Peering_Group_Name> remote-as <IP Transit or Peering ASN>

router bgp <CPE_ASN> neighbor-group <IP_Transit_and_Peering_Group_Name> address-family ipv4 unicast route-policy import_policy_IP_Transit_and_Peering in

router bgp <CPE_ASN> neighbor-group <IP_Transit_and_Peering_Group_Name> address-family ipv6 unicast route-policy import_policy_IP_Transit_and_Peering in

route-policy import_policy_IP_Transit_and_Peering

  if (destination in AKAMAI_Direct Connect_plist_v4)  then

    drop

  elseif (destination in AKAMAI_Direct Connect_plist_v6) then

    drop

  elseif <other terms continues here>

  endif

end-policy

prefix-set AKAMAI_Direct Connect_plist_v4

 <IPv4 Aggregated Prefix provided by Akamai> ge <Akamai Prefix Mask +1>
end-set

prefix-set AKAMAI_Direct Connect_plist_v6

 <IPv4 Aggregated Prefix provided by Akamai> ge <Akamai Prefix Mask+1>
end-set

Did this page help you?